virtualjaguar-2.1.2-r1.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils versionator qt4-r2 gnome2-utils toolchain-funcs games
  5. DESCRIPTION="an Atari Jaguar emulator"
  6. HOMEPAGE="http://www.icculus.org/virtualjaguar/"
  7. SRC_URI="http://www.icculus.org/virtualjaguar/tarballs/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE=""
  12. RDEPEND="media-libs/libsdl[joystick,opengl,sound,video]
  13. sys-libs/zlib
  14. virtual/opengl
  15. dev-qt/qtcore:4
  16. dev-qt/qtgui:4
  17. dev-qt/qtopengl:4[-egl]
  18. dev-libs/libcdio"
  19. DEPEND="${RDEPEND}
  20. >=sys-devel/gcc-4.4"
  21. S=${WORKDIR}/${PN}
  22. pkg_pretend() {
  23. local ver=4.4
  24. if ! version_is_at_least ${ver} $(gcc-version); then
  25. die "${PN} needs at least gcc ${ver} selected to compile."
  26. fi
  27. }
  28. src_prepare() {
  29. sed -i \
  30. -e '/^Categories/s/$/;/' \
  31. virtualjaguar.desktop || die
  32. }
  33. src_configure() {
  34. eqmake4 virtualjaguar.pro -o makefile-qt
  35. }
  36. src_compile() {
  37. emake -j1 libs
  38. emake
  39. }
  40. src_install() {
  41. dogamesbin ${PN}
  42. dodoc README docs/{TODO,WHATSNEW}
  43. doman docs/virtualjaguar.1
  44. domenu virtualjaguar.desktop
  45. newicon -s 128 res/vj-icon.png ${PN}.png
  46. prepgamesdirs
  47. }
  48. pkg_preinst() {
  49. games_pkg_preinst
  50. gnome2_icon_savelist
  51. }
  52. pkg_postinst() {
  53. games_pkg_postinst
  54. elog "The ${PN} ROM path is no-longer hardcoded, "
  55. elog "set it from within, the ${PN} GUI."
  56. elog
  57. elog "The ROM extension supported by ${PN} is .j64, "
  58. elog ".jag files will be interpreted as Jaguar Server executables."
  59. gnome2_icon_cache_update
  60. }
  61. pkg_postrm() {
  62. gnome2_icon_cache_update
  63. }