virtualjaguar-2.1.2-r2.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils versionator gnome2-utils qmake-utils toolchain-funcs
  5. DESCRIPTION="an Atari Jaguar emulator"
  6. HOMEPAGE="http://www.icculus.org/virtualjaguar/"
  7. SRC_URI="http://www.icculus.org/virtualjaguar/tarballs/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. dev-libs/libcdio
  14. dev-qt/qtcore:4
  15. dev-qt/qtgui:4
  16. dev-qt/qtopengl:4[-egl]
  17. media-libs/libsdl[joystick,opengl,sound,video]
  18. sys-libs/zlib
  19. virtual/opengl"
  20. DEPEND="${RDEPEND}
  21. >=sys-devel/gcc-4.4"
  22. S=${WORKDIR}/${PN}
  23. pkg_pretend() {
  24. local ver=4.4
  25. if tc-is-gcc && ! version_is_at_least ${ver} $(gcc-version); then
  26. die "${PN} needs at least gcc ${ver} selected to compile."
  27. fi
  28. }
  29. src_prepare() {
  30. default
  31. sed -i \
  32. -e '/^Categories/s/$/;/' \
  33. virtualjaguar.desktop || die
  34. }
  35. src_configure() {
  36. eqmake4 virtualjaguar.pro -o makefile-qt
  37. }
  38. src_compile() {
  39. emake -j1 libs
  40. emake
  41. }
  42. src_install() {
  43. dobin ${PN}
  44. dodoc README docs/{TODO,WHATSNEW}
  45. doman docs/virtualjaguar.1
  46. domenu virtualjaguar.desktop
  47. newicon -s 128 res/vj-icon.png ${PN}.png
  48. }
  49. pkg_preinst() {
  50. gnome2_icon_savelist
  51. }
  52. pkg_postinst() {
  53. elog "The ${PN} ROM path is no-longer hardcoded, "
  54. elog "set it from within, the ${PN} GUI."
  55. elog
  56. elog "The ROM extension supported by ${PN} is .j64, "
  57. elog ".jag files will be interpreted as Jaguar Server executables."
  58. gnome2_icon_cache_update
  59. }
  60. pkg_postrm() {
  61. gnome2_icon_cache_update
  62. }