fortune-mod-gentoo-forums-20041207.ebuild 834 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Fortune database of quotes from forums.gentoo.org"
  5. HOMEPAGE="https://forums.gentoo.org/"
  6. SRC_URI="mirror://gentoo/gentoo-forums-${PV}.gz
  7. offensive? ( mirror://gentoo/gentoo-forums-offensive-${PV}.gz )"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  11. IUSE="offensive"
  12. DEPEND="games-misc/fortune-mod"
  13. RDEPEND="${DEPEND}"
  14. S=${WORKDIR}
  15. src_compile() {
  16. mv gentoo-forums-${PV} gentoo-forums || die
  17. use offensive && cat gentoo-forums-offensive-${PV} >> gentoo-forums
  18. strfile gentoo-forums || die
  19. }
  20. src_install() {
  21. insinto /usr/share/fortune
  22. doins gentoo-forums gentoo-forums.dat
  23. }