qlife-1.1.ebuild 694 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils qt4-r2 games
  5. MY_PN=${PN/ql/QL}
  6. DESCRIPTION="Simulates the classical Game of Life invented by John Conway"
  7. HOMEPAGE="http://open-maker.tuxfamily.org/blog/index.php?post/2009/03/28/QLife"
  8. SRC_URI="http://open-maker.tuxfamily.org/blog/public/${PN}_linux.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86"
  12. IUSE=""
  13. DEPEND="dev-qt/qtgui:4"
  14. RDEPEND="${DEPEND}"
  15. S=${WORKDIR}/${MY_PN}/sources
  16. src_configure() {
  17. eqmake4 ${MY_PN}.pro
  18. }
  19. src_install() {
  20. dogamesbin ${MY_PN}
  21. newicon data/egg.png ${PN}.png
  22. make_desktop_entry ${MY_PN} ${MY_PN}
  23. prepgamesdirs
  24. }