xcowsay-1.3.ebuild 758 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. DESCRIPTION="configurable talking graphical cow (inspired by cowsay)"
  5. HOMEPAGE="http://www.doof.me.uk/xcowsay/"
  6. SRC_URI="http://www.nickg.me.uk/files/${P}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE="dbus fortune"
  11. RDEPEND="dbus? ( sys-apps/dbus )
  12. dev-libs/dbus-glib
  13. fortune? ( games-misc/fortune-mod )
  14. media-libs/freetype:2
  15. media-libs/libpng
  16. x11-libs/pango
  17. x11-libs/gtk+:2
  18. x11-libs/gdk-pixbuf:2"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. src_configure() {
  22. econf $(use_enable dbus)
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" install || die "emake failed"
  26. if ! use fortune; then
  27. rm -f "${D}"/usr/bin/xcowfortune
  28. fi
  29. }