adom-1.1.1-r1.ebuild 857 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="Ancient Domains Of Mystery rogue-like game"
  6. HOMEPAGE="http://www.adom.de/"
  7. SRC_URI="http://www.adom.de/adom/download/linux/${P//.}-elf.tar.gz"
  8. LICENSE="adom"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RESTRICT="strip" #bug #137340
  13. QA_FLAGS_IGNORED="${GAMES_PREFIX_OPT:1}/bin/adom"
  14. RDEPEND="|| (
  15. >=sys-libs/ncurses-5.9-r3:0/5[abi_x86_32(-)]
  16. >=sys-libs/ncurses-5.9-r3:5/5[abi_x86_32(-)] )"
  17. S=${WORKDIR}/${PN}
  18. src_install() {
  19. exeinto "${GAMES_PREFIX_OPT}/bin"
  20. doexe adom
  21. keepdir "${GAMES_STATEDIR}/${PN}"
  22. echo "${GAMES_STATEDIR}/${PN}" > adom_ds.cfg
  23. insinto /etc
  24. doins adom_ds.cfg
  25. edos2unix adomfaq.txt
  26. dodoc adomfaq.txt manual.doc readme.1st
  27. prepgamesdirs
  28. fperms g+w "${GAMES_STATEDIR}/${PN}"
  29. }