powder-117.ebuild 915 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic games
  5. MY_P=${P/-/}_src
  6. DESCRIPTION="A game in the genre of Rogue, Nethack, and Diablo. Emphasis is on tactical play"
  7. HOMEPAGE="http://www.zincland.com/powder/"
  8. SRC_URI="http://www.zincland.com/powder/release/${MY_P}.tar.gz"
  9. LICENSE="CC-Sampling-Plus-1.0"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. DEPEND="media-libs/libsdl[video]"
  14. RDEPEND=${DEPEND}
  15. S=${WORKDIR}/${MY_P}
  16. src_compile() {
  17. append-cxxflags -DCHANGE_WORK_DIRECTORY
  18. emake -C port/linux premake
  19. emake -C port/linux powder
  20. }
  21. src_install() {
  22. dogamesbin port/linux/${PN}
  23. dodoc README.TXT CREDITS.TXT
  24. prepgamesdirs
  25. }
  26. pkg_postinst() {
  27. elog "While the highscore is kept, save games are never preserved between"
  28. elog "versions. Please wait until your current character dies before upgrading."
  29. games_pkg_postinst
  30. }