avadon-1.0.4.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils unpacker games
  5. DESCRIPTION="Epic fantasy role-playing adventure in an enormous and unique world"
  6. HOMEPAGE="http://www.spiderwebsoftware.com/avadon/index.html"
  7. SRC_URI="avadon-black-fortress_${PV}_all.run"
  8. LICENSE="all-rights-reserved"
  9. SLOT="0"
  10. KEYWORDS="-* amd64 x86"
  11. IUSE=""
  12. RESTRICT="fetch bindist"
  13. QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/Avadon*"
  14. RDEPEND="media-libs/libsdl[X,opengl,video]
  15. media-libs/openal"
  16. DEPEND="app-arch/unzip"
  17. S=${WORKDIR}/data
  18. pkg_nofetch() {
  19. einfo
  20. einfo "Please buy & download \"${SRC_URI}\" from:"
  21. einfo " ${HOMEPAGE}"
  22. einfo "and move/link it to \"${DISTDIR}\""
  23. einfo
  24. }
  25. src_unpack() {
  26. unpack_zip ${A}
  27. }
  28. src_install() {
  29. local dir=${GAMES_PREFIX_OPT}/${PN}
  30. local arch=$(usex amd64 "amd64" "x86")
  31. insinto "${dir}"
  32. doins -r "avadon files" icon.bmp
  33. exeinto "${dir}"
  34. doexe Avadon-${arch}
  35. newicon Avadon.png ${PN}.png
  36. games_make_wrapper ${PN} "./Avadon-${arch}" "${dir}"
  37. make_desktop_entry ${PN} "Avadon: The Black Fortress"
  38. dodoc README-linux.txt
  39. prepgamesdirs
  40. }