daimonin-client-0.10.5-r1.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils autotools
  5. MY_P=${PN}-${PV}
  6. DESCRIPTION="a graphical 2D tile-based MMORPG"
  7. HOMEPAGE="http://daimonin.sourceforge.net/"
  8. SRC_URI="http://daimonin.svn.sourceforge.net/viewvc/daimonin/main/client/?view=tar&pathrev=6021
  9. -> daimonin-client-0.10.5.tar.gz
  10. music? ( mirror://sourceforge/daimonin/Addon%20packs/Music/AllMusic.zip
  11. -> daimonin-client-AllMusic-20100827.zip )"
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="~amd64 ~ppc ~x86"
  15. IUSE="debug music"
  16. RDEPEND="
  17. dev-games/physfs
  18. media-libs/libsdl[sound,video]
  19. media-libs/sdl-image[png]
  20. media-libs/sdl-mixer[vorbis]
  21. net-misc/curl"
  22. DEPEND="${RDEPEND}
  23. music? ( app-arch/unzip )"
  24. S=${WORKDIR}/client/make/linux
  25. PATCHES=(
  26. "${FILESDIR}"/${P}-nozlib.patch
  27. )
  28. src_unpack() {
  29. unpack ${MY_P}.tar.gz
  30. if use music ; then
  31. cd client/media || die
  32. rm -f * || die
  33. unpack ${PN}-AllMusic-20100827.zip
  34. fi
  35. }
  36. src_prepare() {
  37. default
  38. rm ../../src/include/z{lib,conf}.h || die
  39. sed -i \
  40. -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
  41. -e '/PROGRAMS/s:daimonin-updater::' \
  42. Makefile.am \
  43. || die "sed failed"
  44. eautoreconf
  45. cd ../../src || die
  46. # Not relative to $S, so can't be applied via $PATCHES[@]
  47. eapply "${FILESDIR}"/${P}-datadir.patch
  48. }
  49. src_configure() {
  50. econf \
  51. --disable-simplelayout \
  52. $(use_enable debug)
  53. }
  54. src_install() {
  55. default
  56. cd ../.. || die
  57. dodoc README*
  58. newicon bitmaps/pentagram.png ${PN}.png
  59. make_desktop_entry daimonin Daimonin
  60. }