crossfire-server-1.71.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. MY_P="${P/-server/}"
  6. DESCRIPTION="server for the crossfire clients"
  7. HOMEPAGE="http://crossfire.real-time.com/"
  8. SRC_URI="mirror://sourceforge/crossfire/${PN}/${PV}/${MY_P}.tar.bz2
  9. mirror://sourceforge/crossfire/${PN}/${PV}/${MY_P}.maps.tar.bz2
  10. mirror://sourceforge/crossfire/${PN}/${PV}/${MY_P}.arch.tar.bz2"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~ppc x86"
  14. IUSE="X"
  15. RESTRICT="test"
  16. DEPEND="net-misc/curl
  17. X? (
  18. x11-libs/libXaw
  19. media-libs/libpng:0
  20. )"
  21. RDEPEND=${DEPEND}
  22. src_prepare() {
  23. rm -f "${WORKDIR}"/maps/Info/combine.pl # bug #236205
  24. ln -s "${WORKDIR}/arch" "${S}/lib" || die
  25. epatch "${FILESDIR}"/${P}-format.patch
  26. }
  27. src_configure() {
  28. egamesconf --disable-static
  29. }
  30. src_compile() {
  31. # work around the collect.pl locking
  32. emake -j1 -C lib
  33. emake
  34. }
  35. src_install() {
  36. default
  37. keepdir "${GAMES_STATEDIR}"/crossfire/{account,datafiles,maps,players,template-maps,unique-items}
  38. insinto "${GAMES_DATADIR}/crossfire"
  39. doins -r "${WORKDIR}/maps"
  40. prune_libtool_files --modules
  41. prepgamesdirs
  42. }