cyphesis-0.6.2-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit toolchain-funcs autotools python-single-r1 eutils
  6. DESCRIPTION="WorldForge server running small games"
  7. HOMEPAGE="http://worldforge.org/index.php/components/cyphesis/"
  8. SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RESTRICT="test"
  14. RDEPEND="
  15. dev-db/postgresql:=
  16. >=dev-games/mercator-0.3.3
  17. >=dev-games/wfmath-1.0.1
  18. dev-libs/libgcrypt:0
  19. dev-libs/libsigc++:2
  20. sys-libs/ncurses:0
  21. sys-libs/readline:0
  22. >=media-libs/atlas-c++-0.6.3
  23. >=media-libs/skstream-0.3.9
  24. >=media-libs/varconf-0.6.4
  25. "
  26. DEPEND="${RDEPEND}
  27. >=dev-libs/boost-1.40
  28. dev-libs/libxml2
  29. virtual/pkgconfig"
  30. pkg_setup() {
  31. python-single-r1_pkg_setup
  32. }
  33. PATCHES=(
  34. "${FILESDIR}"/${P}-gentoo.patch
  35. "${FILESDIR}"/${P}-makefile.patch
  36. )
  37. src_prepare() {
  38. default
  39. eautoreconf
  40. }
  41. src_configure() {
  42. econf --localstatedir=/var
  43. }
  44. src_compile() {
  45. emake AR="$(tc-getAR)"
  46. }
  47. src_install() {
  48. emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" install
  49. dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
  50. }