cyphesis-0.6.2.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit toolchain-funcs autotools python-single-r1 eutils games
  6. DESCRIPTION="WorldForge server running small games"
  7. HOMEPAGE="http://worldforge.org/index.php/components/cyphesis/"
  8. SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. RESTRICT="test"
  14. RDEPEND=">=media-libs/skstream-0.3.9
  15. >=dev-games/wfmath-1.0.1
  16. >=dev-games/mercator-0.3.3
  17. dev-libs/libgcrypt:0
  18. dev-libs/libsigc++:2
  19. sys-libs/ncurses:0
  20. sys-libs/readline:0
  21. >=media-libs/atlas-c++-0.6.3
  22. >=media-libs/varconf-0.6.4
  23. dev-db/postgresql:="
  24. DEPEND="${RDEPEND}
  25. >=dev-libs/boost-1.40
  26. dev-libs/libxml2
  27. virtual/pkgconfig"
  28. pkg_setup() {
  29. python-single-r1_pkg_setup
  30. games_pkg_setup
  31. }
  32. src_prepare() {
  33. epatch \
  34. "${FILESDIR}"/${P}-gentoo.patch \
  35. "${FILESDIR}"/${P}-makefile.patch
  36. eautoreconf
  37. }
  38. src_configure() {
  39. egamesconf \
  40. --localstatedir=/var
  41. }
  42. src_compile() {
  43. emake AR="$(tc-getAR)"
  44. }
  45. src_install() {
  46. emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
  47. install
  48. dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
  49. prepgamesdirs
  50. }