grfcodec-6.0.5.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [ "${PV%9999}" != "${PV}" ] ; then
  5. SCM=mercurial
  6. EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
  7. fi
  8. inherit toolchain-funcs ${SCM}
  9. DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
  10. HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
  11. [[ -z ${SCM} ]] && SRC_URI="http://binaries.openttd.org/extra/${PN}/${PV}/${P}-source.tar.xz"
  12. LICENSE="GPL-2+"
  13. SLOT="0"
  14. KEYWORDS="amd64 ~arm ppc ppc64 x86"
  15. IUSE=""
  16. [[ -n ${SCM} ]] && S=${WORKDIR}/${PN}
  17. RDEPEND="media-libs/libpng:0"
  18. DEPEND="${RDEPEND}
  19. !games-util/nforenum
  20. dev-lang/perl
  21. dev-libs/boost"
  22. src_prepare() {
  23. # Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
  24. cat > Makefile.local <<-__EOF__
  25. CXX=$(tc-getCXX)
  26. BOOST_INCLUDE=/usr/include
  27. CXXFLAGS=${CXXFLAGS}
  28. LDOPT=${LDFLAGS}
  29. UPX=
  30. V=1
  31. FLAGS=
  32. EXE=
  33. __EOF__
  34. sed -i -e 's/-O2//g' Makefile || die
  35. }
  36. src_install() {
  37. dobin grfcodec grfid grfstrip nforenum
  38. doman docs/*.1
  39. dodoc changelog.txt docs/*.txt
  40. }