linux-wbfs-manager-0.1.12.ebuild 919 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [[ "${PV}" == "9999" ]]; then
  5. ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
  6. inherit toolchain-funcs subversion
  7. SRC_URI=""
  8. #KEYWORDS=""
  9. else
  10. inherit toolchain-funcs
  11. SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
  12. KEYWORDS="amd64 ~ppc x86"
  13. fi;
  14. DESCRIPTION="WBFS manager for Linux using GTK+"
  15. HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
  16. LICENSE="GPL-2"
  17. SLOT="0"
  18. IUSE=""
  19. RDEPEND="dev-libs/glib:2
  20. gnome-base/libglade:2.0"
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig"
  23. if [[ ${PV} == "9999" ]] ; then
  24. S=${WORKDIR}/${ECVS_MODULE}
  25. else
  26. S=${WORKDIR}/${PN}
  27. fi
  28. src_unpack() {
  29. if [[ ${PV} == "9999" ]]; then
  30. subversion_src_unpack
  31. else
  32. default
  33. fi
  34. }
  35. src_compile() {
  36. emake CC="$(tc-getCC)"
  37. }
  38. src_install() {
  39. dobin wbfs_gtk
  40. dodoc README
  41. }