pogo-manager-bin-0.1.6.ebuild 813 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN="${PN/-bin}"
  5. DESCRIPTION="Pokemon Go manager"
  6. HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
  7. SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
  8. LICENSE="CC-BY-NC-SA-4.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. IUSE=""
  12. RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
  13. DEPEND="app-arch/unzip"
  14. S="${WORKDIR}/BPGM_v${PV}"
  15. src_install()
  16. {
  17. insinto /opt/${MY_PN}
  18. newins BlossomsPogoManager.jar ${MY_PN}.jar
  19. dobin "${FILESDIR}/pogo-manager"
  20. }
  21. pkg_postinst()
  22. {
  23. ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
  24. ewarn "You have been warned!"
  25. }