umodpack-0.5_beta16-r2.ebuild 970 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit perl-module toolchain-funcs
  5. MY_P=${P/_beta/b}
  6. DESCRIPTION="portable and useful [un]packer for Unreal Tournament's Umod files"
  7. HOMEPAGE="http://www.oldunreal.com/wiki/index.php?title=UmodPack"
  8. SRC_URI="mirror://gentoo/${MY_P}-allinone.tar.gz"
  9. LICENSE="Artistic"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86"
  12. IUSE="tk"
  13. DEPEND="virtual/perl-IO-Compress
  14. dev-perl/Archive-Zip
  15. dev-perl/Tie-IxHash
  16. tk? ( dev-perl/Tk )"
  17. RDEPEND=${DEPEND}
  18. S=${WORKDIR}/${MY_P}
  19. SRC_TEST="do parallel"
  20. src_prepare() {
  21. # remove the stupid perl modules since we already installed em
  22. rm -rf {Archive-Zip,Compress-Zlib,Tie-IxHash,Tk}* || die
  23. }
  24. src_compile() {
  25. perl-module_src_compile
  26. cd umr-0.3 || die
  27. emake DEBUG=0 CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
  28. }
  29. src_install() {
  30. mydoc="Changes"
  31. perl-module_src_install
  32. dobin umod umr-0.3/umr
  33. if use tk ; then
  34. dobin xumod
  35. fi
  36. }