assogiate-0.2.1-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="yes"
  5. inherit autotools eutils flag-o-matic gnome2
  6. DESCRIPTION="assoGiate is an editor of the file types database for GNOME"
  7. HOMEPAGE="http://www.kdau.com/projects/assogiate"
  8. SRC_URI="http://www.kdau.com/files/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~sparc x86"
  12. IUSE=""
  13. RDEPEND="
  14. >=dev-libs/glib-2.8:2
  15. >=dev-cpp/glibmm-2.46:2
  16. >=dev-cpp/gtkmm-2.24.4-r3:2.4
  17. >=dev-cpp/libxmlpp-2.40:2.6
  18. >=dev-cpp/gnome-vfsmm-2.26.0-r1
  19. "
  20. DEPEND="${RDEPEND}
  21. app-text/gnome-doc-utils
  22. dev-util/intltool
  23. virtual/pkgconfig
  24. "
  25. DOCS="AUTHORS ChangeLog NEWS README TODO"
  26. src_prepare() {
  27. # Fix desktop file
  28. epatch "${FILESDIR}"/${P}-desktop.patch
  29. # Fix compilation, bug #374911
  30. epatch "${FILESDIR}"/${P}-typedialog.patch
  31. # Fix building with glib-2.32, bug #417765
  32. epatch "${FILESDIR}"/${P}-glib-2.32.patch
  33. # Fix building with gcc-4.7
  34. epatch "${FILESDIR}"/${P}-gcc-4.7.patch
  35. eautoreconf
  36. gnome2_src_prepare
  37. append-cxxflags -std=c++11
  38. }