evolution-data-server-3.22.7.ebuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
  6. VALA_USE_DEPEND="vapigen"
  7. inherit db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
  8. DESCRIPTION="Evolution groupware backend"
  9. HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
  10. # Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
  11. LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
  12. SLOT="0/59" # subslot = libcamel-1.2 soname version
  13. IUSE="api-doc-extras berkdb +gnome-online-accounts +gtk google +introspection ipv6 ldap kerberos vala +weather"
  14. REQUIRED_USE="vala? ( introspection )"
  15. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  16. # sys-libs/db is only required for migrating from <3.13 versions
  17. # gdata-0.17.7 soft required for new gdata_feed_get_next_page_token API to handle more than 100 google tasks
  18. # berkdb needed only for migrating old calendar data, bug #519512
  19. gdata_depend=">=dev-libs/libgdata-0.17.7:="
  20. RDEPEND="
  21. >=app-crypt/gcr-3.4
  22. >=app-crypt/libsecret-0.5[crypt]
  23. >=dev-db/sqlite-3.7.17:=
  24. >=dev-libs/glib-2.46:2
  25. >=dev-libs/libical-0.43:=
  26. >=dev-libs/libxml2-2
  27. >=dev-libs/nspr-4.4:=
  28. >=dev-libs/nss-3.9:=
  29. >=net-libs/libsoup-2.42:2.4
  30. dev-libs/icu:=
  31. sys-libs/zlib:=
  32. virtual/libiconv
  33. berkdb? ( >=sys-libs/db-4:= )
  34. gtk? (
  35. >=app-crypt/gcr-3.4[gtk]
  36. >=x11-libs/gtk+-3.10:3
  37. )
  38. google? (
  39. >=dev-libs/json-glib-1.0.4
  40. >=net-libs/webkit-gtk-2.11.91:4
  41. ${gdata_depend}
  42. )
  43. gnome-online-accounts? (
  44. >=net-libs/gnome-online-accounts-3.8:=
  45. ${gdata_depend} )
  46. introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
  47. kerberos? ( virtual/krb5:= )
  48. ldap? ( >=net-nds/openldap-2:= )
  49. weather? ( >=dev-libs/libgweather-3.10:2= )
  50. "
  51. DEPEND="${RDEPEND}
  52. ${PYTHON_DEPS}
  53. dev-util/gdbus-codegen
  54. dev-util/gperf
  55. >=dev-util/gtk-doc-am-1.14
  56. >=dev-util/intltool-0.35.5
  57. >=gnome-base/gnome-common-2
  58. >=sys-devel/gettext-0.17
  59. virtual/pkgconfig
  60. vala? ( $(vala_depend) )
  61. "
  62. # Some tests fail due to missings locales.
  63. # Also, dbus tests are flacky, bugs #397975 #501834
  64. # It looks like a nightmare to disable those for now.
  65. RESTRICT="test"
  66. pkg_setup() {
  67. python-any-r1_pkg_setup
  68. }
  69. src_prepare() {
  70. use vala && vala_src_prepare
  71. gnome2_src_prepare
  72. }
  73. src_configure() {
  74. # /usr/include/db.h is always db-1 on FreeBSD
  75. # so include the right dir in CPPFLAGS
  76. use berkdb && append-cppflags "-I$(db_includedir)"
  77. local gdata_flag
  78. if use google || use gnome-online-accounts; then
  79. gdata_flag="--enable-google"
  80. else
  81. gdata_flag="--disable-google"
  82. fi
  83. # phonenumber does not exist in tree
  84. gnome2_src_configure \
  85. $(use_enable api-doc-extras gtk-doc) \
  86. $(use_with api-doc-extras private-docs) \
  87. $(usex berkdb --with-libdb="${EPREFIX}"/usr --with-libdb=no) \
  88. $(use_enable gnome-online-accounts goa) \
  89. $(use_enable gtk) \
  90. $(use_enable google google-auth) \
  91. ${gdata_flag} \
  92. $(use_enable introspection) \
  93. $(use_enable ipv6) \
  94. $(use_with kerberos krb5 "${EPREFIX}"/usr) \
  95. $(use_with kerberos krb5-libs "${EPREFIX}"/usr/$(get_libdir)) \
  96. $(use_with ldap openldap) \
  97. $(use_enable vala vala-bindings) \
  98. $(use_enable weather) \
  99. --enable-largefile \
  100. --enable-smime \
  101. --with-systemduserunitdir="$(systemd_get_userunitdir)" \
  102. --without-phonenumber \
  103. --disable-examples \
  104. --disable-uoa
  105. }
  106. src_test() {
  107. unset ORBIT_SOCKETDIR
  108. unset SESSION_MANAGER
  109. virtx emake check
  110. }
  111. src_install() {
  112. gnome2_src_install
  113. if use ldap; then
  114. insinto /etc/openldap/schema
  115. doins "${FILESDIR}"/calentry.schema
  116. dosym /usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
  117. fi
  118. }