gnome-calculator-3.22.3.ebuild 817 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="A calculator application for GNOME"
  6. HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. IUSE=""
  10. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. COMMON_DEPEND="
  12. >=dev-libs/glib-2.40:2
  13. dev-libs/libxml2:2
  14. dev-libs/mpfr:0
  15. >=net-libs/libsoup-2.42:2.4
  16. >=x11-libs/gtk+-3.11.6:3
  17. >=x11-libs/gtksourceview-3.15.1:3.0
  18. "
  19. RDEPEND="${COMMON_DEPEND}
  20. !<gnome-extra/gnome-utils-2.3
  21. !gnome-extra/gcalctool
  22. "
  23. DEPEND="${COMMON_DEPEND}
  24. app-text/yelp-tools
  25. >=dev-util/intltool-0.50
  26. sys-devel/gettext
  27. virtual/pkgconfig
  28. "
  29. src_configure() {
  30. gnome2_src_configure \
  31. --disable-static \
  32. VALAC=$(type -P true)
  33. }