gnome-contacts-3.22.1.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. VALA_USE_DEPEND="vapigen"
  5. VALA_MIN_API_VERSION="0.24"
  6. inherit gnome2 vala
  7. DESCRIPTION="GNOME contact management application"
  8. HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
  9. LICENSE="GPL-2+"
  10. SLOT="0"
  11. IUSE="v4l"
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  13. VALA_DEPEND="
  14. $(vala_depend)
  15. >=dev-libs/gobject-introspection-0.9.6:=
  16. dev-libs/folks[vala(+)]
  17. gnome-base/gnome-desktop:3=[introspection]
  18. gnome-extra/evolution-data-server[vala]
  19. net-libs/telepathy-glib[vala]
  20. "
  21. # Configure is wrong; it needs cheese-3.5.91, not 3.3.91
  22. RDEPEND="
  23. >=dev-libs/folks-0.9.5:=[eds,telepathy]
  24. >=dev-libs/glib-2.37.6:2
  25. >=dev-libs/libgee-0.10:0.8
  26. >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
  27. >=gnome-base/gnome-desktop-3.0:3=
  28. media-libs/clutter:1.0
  29. media-libs/clutter-gtk:1.0
  30. media-libs/libchamplain:0.12
  31. net-libs/gnome-online-accounts:=
  32. >=net-libs/telepathy-glib-0.17.5
  33. >=sci-geosciences/geocode-glib-3.15.3
  34. x11-libs/cairo:=
  35. x11-libs/gdk-pixbuf:2
  36. >=x11-libs/gtk+-3.20.0:3
  37. x11-libs/pango
  38. v4l? ( >=media-video/cheese-3.5.91:= )
  39. "
  40. DEPEND="${RDEPEND}
  41. ${VALA_DEPEND}
  42. app-text/docbook-xml-dtd:4.2
  43. app-text/docbook-xsl-stylesheets
  44. dev-libs/libxslt
  45. >=dev-util/intltool-0.40
  46. >=sys-devel/gettext-0.17
  47. virtual/pkgconfig
  48. "
  49. src_prepare() {
  50. # Regenerate the pre-generated C sources, bug #471628
  51. if ! use v4l; then
  52. touch src/*.vala
  53. fi
  54. vala_src_prepare
  55. gnome2_src_prepare
  56. }
  57. src_configure() {
  58. gnome2_src_configure \
  59. --enable-man-pages \
  60. $(use_with v4l cheese)
  61. }