gnome-shell-frippery-3.20.0.ebuild 914 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Unofficial extension pack providing GNOME 2-like features for GNOME 3"
  5. HOMEPAGE="http://frippery.org/extensions/index.html"
  6. SRC_URI="http://frippery.org/extensions/${P}.tgz"
  7. LICENSE="GPL-2+"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE=""
  11. RDEPEND="
  12. app-eselect/eselect-gnome-shell-extensions
  13. >=dev-libs/gjs-1.29
  14. dev-libs/gobject-introspection:=
  15. gnome-base/gnome-menus:3[introspection]
  16. >=gnome-base/gnome-shell-3.20
  17. media-libs/clutter:1.0[introspection]
  18. x11-libs/pango[introspection]
  19. "
  20. DEPEND=""
  21. S="${WORKDIR}/.local/share/gnome-shell"
  22. src_install() {
  23. insinto /usr/share/gnome-shell/extensions
  24. doins -r extensions/*@*
  25. dodoc gnome-shell-frippery/{CHANGELOG,README}
  26. }
  27. pkg_postinst() {
  28. ebegin "Updating list of installed extensions"
  29. eselect gnome-shell-extensions update
  30. eend $?
  31. }