gnome-user-share-3.18.3.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit gnome2 multilib systemd
  6. DESCRIPTION="Personal file sharing for the GNOME desktop"
  7. HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. # FIXME: could libnotify be made optional ?
  13. # FIXME: selinux automagic support
  14. RDEPEND="
  15. >=dev-libs/glib-2.28:2
  16. >=x11-libs/gtk+-3:3
  17. >=gnome-base/nautilus-2.91.7
  18. media-libs/libcanberra[gtk3]
  19. >=www-apache/mod_dnssd-0.6
  20. >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]
  21. >=x11-libs/libnotify-0.7:=
  22. "
  23. DEPEND="${RDEPEND}
  24. !<gnome-base/gnome-control-center-3.9
  25. app-text/yelp-tools
  26. app-text/docbook-xml-dtd:4.1.2
  27. >=dev-util/intltool-0.35
  28. sys-devel/gettext
  29. virtual/pkgconfig
  30. "
  31. PATCHES=(
  32. # Upstream forces to use prefork because of Fedora defaults, but
  33. # that is problematic for us (bug #551012)
  34. # https://bugzilla.gnome.org/show_bug.cgi?id=750525#c2
  35. "${FILESDIR}"/${PN}-3.18.1-no-prefork.patch
  36. )
  37. src_configure() {
  38. gnome2_src_configure \
  39. --with-httpd=apache2 \
  40. --with-modules-path=/usr/$(get_libdir)/apache2/modules/ \
  41. --with-systemduserunitdir="$(systemd_get_userunitdir)"
  42. }