gnome-weather-3.18.1.ebuild 773 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. inherit gnome2 virtualx
  6. DESCRIPTION="A weather application for GNOME"
  7. HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
  8. LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="test"
  12. RDEPEND="
  13. >=dev-libs/gjs-1.43.3
  14. >=dev-libs/glib-2.32:2
  15. >=dev-libs/gobject-introspection-1.35.9:=
  16. >=dev-libs/libgweather-3.17.2:=
  17. >=x11-libs/gtk+-3.11.4:3
  18. "
  19. DEPEND="${RDEPEND}
  20. dev-libs/appstream-glib
  21. >=dev-util/intltool-0.26
  22. virtual/pkgconfig
  23. test? ( dev-util/dogtail )
  24. "
  25. src_configure() {
  26. gnome2_src_configure $(use_enable test dogtail)
  27. }
  28. src_test() {
  29. Xemake check TESTS_ENVIRONMENT="dbus-run-session"
  30. }