gnome-weather-3.20.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. inherit gnome2 python-any-r1 virtualx
  6. DESCRIPTION="A weather application for GNOME"
  7. HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
  8. LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="test"
  12. RDEPEND="
  13. >=app-misc/geoclue-2.3.1:2.0
  14. >=dev-libs/gjs-1.43.3
  15. >=dev-libs/glib-2.32:2
  16. >=dev-libs/gobject-introspection-1.35.9:=
  17. >=dev-libs/libgweather-3.17.2:=
  18. gnome-base/gsettings-desktop-schemas
  19. >=x11-libs/gtk+-3.11.4:3
  20. "
  21. DEPEND="${RDEPEND}
  22. dev-libs/appstream-glib
  23. >=dev-util/intltool-0.26
  24. virtual/pkgconfig
  25. test? (
  26. ${PYTHON_DEPS}
  27. $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
  28. "
  29. python_check_deps() {
  30. use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
  31. }
  32. pkg_setup() {
  33. use test && python-any-r1_pkg_setup
  34. }
  35. src_configure() {
  36. gnome2_src_configure $(use_enable test dogtail)
  37. }
  38. src_test() {
  39. virtx emake check TESTS_ENVIRONMENT="dbus-run-session"
  40. }