nautilus-sendto-3.8.3.ebuild 749 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="yes"
  5. inherit gnome2
  6. DESCRIPTION="A nautilus extension for sending files to locations"
  7. HOMEPAGE="https://git.gnome.org/browse/nautilus-sendto/"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  11. IUSE=""
  12. RDEPEND="
  13. >=x11-libs/gtk+-2.90.3:3[X(+)]
  14. "
  15. DEPEND="${RDEPEND}
  16. >=dev-util/gtk-doc-am-1.9
  17. >=dev-util/intltool-0.35
  18. sys-devel/gettext
  19. virtual/pkgconfig
  20. "
  21. # Needed for eautoreconf
  22. # >=gnome-base/gnome-common-0.12
  23. src_prepare() {
  24. gnome2_src_prepare
  25. # Does not require introspection at all, bug #561008
  26. sed -i -e 's/\(^ \+enable_introspection\)=yes/\1=no/' configure || die
  27. }