nemo-3.2.0.ebuild 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python3_4 )
  6. inherit autotools eutils gnome2 python-any-r1 virtualx
  7. DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
  8. HOMEPAGE="http://cinnamon.linuxmint.com/"
  9. SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="exif +introspection +nls packagekit tracker xmp"
  14. COMMON_DEPEND="
  15. >=dev-libs/glib-2.37.3:2[dbus]
  16. >=gnome-extra/cinnamon-desktop-2.6.1:0=
  17. >=x11-libs/pango-1.28.3
  18. >=x11-libs/gtk+-3.9.10:3[introspection?]
  19. >=dev-libs/libxml2-2.7.8:2
  20. gnome-base/dconf:0=
  21. gnome-base/gsettings-desktop-schemas
  22. >=x11-libs/libnotify-0.7:=
  23. x11-libs/libX11
  24. x11-libs/libXext
  25. x11-libs/libXrender
  26. exif? ( >=media-libs/libexif-0.6.20:= )
  27. introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
  28. tracker? ( >=app-misc/tracker-0.12:= )
  29. xmp? ( >=media-libs/exempi-2.2.0:= )
  30. "
  31. RDEPEND="${COMMON_DEPEND}
  32. x11-themes/adwaita-icon-theme
  33. nls? ( >=gnome-extra/cinnamon-translations-2.2 )
  34. "
  35. PDEPEND=">=gnome-base/gvfs-0.1.2"
  36. DEPEND="${COMMON_DEPEND}
  37. ${PYTHON_DEPS}
  38. $(python_gen_any_dep '
  39. dev-python/polib[${PYTHON_USEDEP}]
  40. dev-python/pygobject:3[${PYTHON_USEDEP}]
  41. ')
  42. >=dev-lang/perl-5
  43. >=dev-util/gdbus-codegen-2.31.0
  44. dev-util/gtk-doc-am
  45. >=dev-util/intltool-0.40.1
  46. sys-devel/gettext
  47. virtual/pkgconfig
  48. x11-proto/xproto
  49. dev-util/gtk-doc
  50. gnome-base/gnome-common
  51. "
  52. # For eautoreconf
  53. # gnome-base/gnome-common, dev-util/gtk-doc (not only -am!)
  54. src_prepare() {
  55. eautoreconf
  56. gnome2_src_prepare
  57. }
  58. src_configure() {
  59. gnome2_src_configure \
  60. $(use_enable exif libexif) \
  61. $(use_enable introspection) \
  62. $(use_enable tracker) \
  63. $(use_enable xmp)
  64. }
  65. src_test() {
  66. "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/libnemo-private" || die
  67. cd src # we don't care about translation tests
  68. GSETTINGS_SCHEMA_DIR="${S}/libnemo-private" virtx emake check
  69. }