yelp-3.22.0.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit autotools gnome2
  6. DESCRIPTION="Help browser for GNOME"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. IUSE=""
  11. KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
  12. RDEPEND="
  13. app-arch/bzip2:=
  14. >=app-arch/xz-utils-4.9:=
  15. dev-db/sqlite:3=
  16. >=dev-libs/glib-2.38:2
  17. >=dev-libs/libxml2-2.6.5:2
  18. >=dev-libs/libxslt-1.1.4
  19. >=gnome-extra/yelp-xsl-3.12
  20. >=net-libs/webkit-gtk-2.7.2:4
  21. >=x11-libs/gtk+-3.13.3:3
  22. x11-themes/adwaita-icon-theme
  23. "
  24. DEPEND="${RDEPEND}
  25. >=dev-util/gtk-doc-am-1.13
  26. >=dev-util/intltool-0.41.0
  27. dev-util/itstool
  28. >=sys-devel/gettext-0.17
  29. virtual/pkgconfig
  30. "
  31. src_prepare() {
  32. # Fix compatibility with Gentoo's sys-apps/man
  33. # https://bugzilla.gnome.org/show_bug.cgi?id=648854
  34. eapply "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch
  35. eautoreconf
  36. gnome2_src_prepare
  37. }
  38. src_configure() {
  39. gnome2_src_configure \
  40. --disable-static \
  41. --enable-bz2 \
  42. --enable-lzma
  43. }
  44. src_install() {
  45. gnome2_src_install
  46. exeinto /usr/libexec/
  47. doexe "${S}"/libyelp/yelp-groff
  48. }