zenity-3.22.0.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
  6. HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
  7. LICENSE="LGPL-2+"
  8. SLOT="0"
  9. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  10. IUSE="debug libnotify webkit"
  11. # TODO: X11 dependency is automagically enabled
  12. RDEPEND="
  13. >=dev-libs/glib-2.8:2
  14. x11-libs/gdk-pixbuf:2
  15. >=x11-libs/gtk+-3:3[X]
  16. x11-libs/libX11
  17. x11-libs/pango
  18. libnotify? ( >=x11-libs/libnotify-0.6.1:= )
  19. webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
  20. "
  21. DEPEND="${RDEPEND}
  22. app-text/yelp-tools
  23. gnome-base/gnome-common
  24. >=sys-devel/gettext-0.19.4
  25. virtual/pkgconfig
  26. "
  27. src_configure() {
  28. gnome2_src_configure \
  29. $(usex debug --enable-debug=yes ' ') \
  30. $(use_enable libnotify) \
  31. $(use_enable webkit webkitgtk) \
  32. PERL=$(type -P false)
  33. }
  34. src_install() {
  35. gnome2_src_install
  36. # Not really needed and prevent us from needing perl
  37. rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
  38. }