cdplayer-0.6.0.ebuild 794 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnustep-2
  5. DESCRIPTION="Small CD Audio Player for GNUstep"
  6. HOMEPAGE="https://github.com/schik/cdplayer"
  7. SRC_URI="https://github.com/schik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. KEYWORDS="~amd64 ~x86"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE="dbus"
  12. DEPEND="dev-libs/libcdio
  13. dev-libs/libcdio-paranoia
  14. gnustep-apps/cynthiune
  15. dbus? ( gnustep-libs/dbuskit )"
  16. RDEPEND="${DEPEND}
  17. !gnustep-libs/cddb"
  18. src_prepare() {
  19. sed -e "s#cdda.h#paranoia/cdda.h#" \
  20. -e "s#paranoia.h#paranoia/paranoia.h#" \
  21. -i AudioCD/AudioCD.h || die "AudioCD.h sed failed"
  22. }
  23. src_compile() {
  24. local myconf=""
  25. use dbus || myconf="${myconf} notifications=no"
  26. egnustep_env
  27. egnustep_make ${myconf}
  28. }