cynthiune-1.0.0.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnustep-2
  5. MY_P=${P/c/C}
  6. DESCRIPTION="Free software and romantic music player for GNUstep"
  7. HOMEPAGE="http://gap.nongnu.org/cynthiune/"
  8. SRC_URI="https://savannah.nongnu.org/download/gap/${MY_P}.tar.gz"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. IUSE="alsa ao flac mad modplug musepack oss timidity vorbis"
  13. # musicbrainz disabled upstream for now
  14. RDEPEND="media-libs/audiofile
  15. media-libs/taglib
  16. alsa? ( media-libs/alsa-lib )
  17. ao? ( media-libs/libao )
  18. flac? ( media-libs/flac )
  19. mad? ( media-libs/libid3tag
  20. media-libs/libmad )
  21. musepack? ( >=media-sound/musepack-tools-444 )
  22. modplug? ( media-libs/libmodplug )
  23. timidity? ( media-sound/timidity++ )
  24. vorbis? ( >=media-libs/libogg-1.1.2
  25. >=media-libs/libvorbis-1.0.1-r2 )"
  26. DEPEND="${RDEPEND}
  27. mad? ( virtual/pkgconfig )"
  28. S=${WORKDIR}/${MY_P}
  29. cynthiune_get_config() {
  30. local myconf="disable-windowsmedia=yes disable-esound=yes"
  31. use alsa || myconf="${myconf} disable-alsa=yes"
  32. use ao || myconf="${myconf} disable-ao=yes"
  33. use flac || myconf="${myconf} disable-flac=yes disable-flactags=yes"
  34. use mad || myconf="${myconf} disable-mp3=yes disable-id3tag=yes"
  35. use modplug || myconf="${myconf} disable-mod=yes"
  36. use musepack || myconf="${myconf} disable-musepack=yes"
  37. use oss || myconf="${myconf} disable-oss=yes"
  38. use timidity || myconf="${myconf} disable-timidity=yes"
  39. use vorbis || myconf="${myconf} disable-ogg=yes disable-vorbistags=yes"
  40. echo ${myconf}
  41. }
  42. src_compile() {
  43. egnustep_env
  44. egnustep_make "$(cynthiune_get_config)"
  45. }
  46. src_install() {
  47. egnustep_env
  48. egnustep_install "$(cynthiune_get_config)"
  49. }