mknfonts-0.5-r1.ebuild 747 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils gnustep-base
  4. DESCRIPTION="A tool to create .nfont packages for use with gnustep-back-art"
  5. HOMEPAGE="http://packages.debian.org/mknfonts.tool"
  6. SRC_URI="mirror://debian/pool/main/m/${PN}.tool/${PN}.tool_${PV}.orig.tar.gz"
  7. KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. IUSE=""
  11. DEPEND="gnustep-base/gnustep-gui
  12. >=media-libs/freetype-2.1"
  13. RDEPEND="${DEPEND}"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. # Correct link command for --as-needed
  18. sed -i -e "s/ADDITIONAL_LDFLAGS/ADDITIONAL_TOOL_LIBS/" GNUmakefile || die "sed failed"
  19. epatch "${FILESDIR}"/${PN}-rename.patch
  20. }