dbuskit-0.1.1.ebuild 739 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools gnustep-2
  5. DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
  6. HOMEPAGE="http://www.gnustep.org"
  7. SRC_URI="http://download.gna.org/gnustep/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND=">=sys-apps/dbus-1.2.1"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. if ! use doc; then
  16. # Remove doc target
  17. sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
  18. || die "doc sed failed"
  19. fi
  20. # Bug 410697
  21. sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
  22. -i configure.ac || die "ObjectiveC2 runtime sed failed"
  23. eautoreconf
  24. }