pantomime-1.2.2.ebuild 756 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils gnustep-2
  5. MY_P=${P/p/P}
  6. S=${WORKDIR}/${MY_P}
  7. DESCRIPTION="A set of Objective-C classes that model a mail system"
  8. HOMEPAGE="http://www.collaboration-world.com/pantomime/"
  9. SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
  10. LICENSE="LGPL-2.1 Elm"
  11. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  12. SLOT="0"
  13. IUSE=""
  14. DEPEND="dev-libs/openssl"
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
  18. Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
  19. }
  20. src_install() {
  21. gnustep-base_src_install
  22. cd "${S}"/Documentation
  23. dodoc AUTHORS README TODO
  24. docinto rfc
  25. dodoc RFC/*
  26. }