sope-3.2.6a.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils gnustep-2 vcs-snapshot
  5. DESCRIPTION="A set of frameworks forming a complete Web application server environment"
  6. HOMEPAGE="http://www.sogo.nu/"
  7. SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
  12. RDEPEND="
  13. sys-libs/zlib
  14. ldap? ( net-nds/openldap )
  15. gnutls? ( net-libs/gnutls:= )
  16. !gnutls? (
  17. !libressl? ( dev-libs/openssl:0= )
  18. libressl? ( dev-libs/libressl:= )
  19. )
  20. mysql? ( virtual/libmysqlclient:= )
  21. postgres? ( dev-db/postgresql:= )
  22. xml? ( dev-libs/libxml2:2 )
  23. "
  24. DEPEND="${RDEPEND}"
  25. pkg_pretend() {
  26. if use ssl && use gnutls && use libressl ; then
  27. ewarn "You have enabled both gnutls and libressl, but only"
  28. ewarn "one provider can be active. Using gnutls!"
  29. fi
  30. }
  31. src_configure() {
  32. local ssl_provider
  33. if use ssl ; then
  34. if use gnutls ; then
  35. ssl_provider=gnutls
  36. else
  37. ssl_provider=ssl
  38. fi
  39. else
  40. ssl_provider=none
  41. fi
  42. egnustep_env
  43. # Non-standard configure script
  44. ./configure \
  45. --disable-strip \
  46. $(use_enable debug) \
  47. $(use_enable ldap openldap) \
  48. $(use_enable mysql) \
  49. $(use_enable postgres postgresql) \
  50. $(use_enable xml) \
  51. --with-ssl="${ssl_provider}" \
  52. --with-gnustep || die "configure failed"
  53. }