baloo-4.14.3_p20161017.ebuild 642 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PV="4.14.3"
  5. inherit kde4-base
  6. DESCRIPTION="Framework for searching and managing metadata"
  7. SRC_URI="
  8. mirror://kde/stable/${MY_PV}/src/${PN}-${MY_PV}.tar.xz
  9. https://dev.gentoo.org/~asturm/${P}.tar.xz
  10. "
  11. KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
  12. IUSE="debug"
  13. DEPEND="
  14. $(add_kdeapps_dep kdepimlibs)
  15. dev-libs/qjson
  16. dev-libs/xapian:=[chert]
  17. "
  18. RDEPEND="${DEPEND}
  19. !<kde-base/nepomuk-4.12.50
  20. "
  21. RESTRICT="test"
  22. PATCHES=( "${WORKDIR}/${P}" ) # intevation branch + disable non-PIM stuff
  23. S="${WORKDIR}/${PN}-${MY_PV}"