bluez-qt-5.29.0.ebuild 506 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. VIRTUALX_REQUIRED="test"
  5. inherit kde5 udev
  6. DESCRIPTION="Qt wrapper for Bluez 5 DBus API"
  7. LICENSE="LGPL-2"
  8. KEYWORDS="amd64 ~arm x86"
  9. IUSE=""
  10. DEPEND="
  11. $(add_qt_dep qtdbus)
  12. $(add_qt_dep qtdeclarative)
  13. $(add_qt_dep qtnetwork)
  14. "
  15. RDEPEND="${DEPEND}
  16. !kde-plasma/bluez-qt
  17. "
  18. src_configure() {
  19. local mycmakeargs=(
  20. -DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d"
  21. )
  22. kde5_src_configure
  23. }