kio-ftps-0.2.ebuild 691 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit kde4-base
  5. DESCRIPTION="KDE ftps KIO slave"
  6. HOMEPAGE="http://kde-apps.org/content/show.php/kio-ftps?content=35875"
  7. SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="4"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. # This is just for some app we can use kio-ftps with
  13. RDEPEND="|| (
  14. $(add_kdeapps_dep konqueror)
  15. $(add_kdeapps_dep dolphin)
  16. )"
  17. S="${WORKDIR}/${PN}"
  18. src_prepare() {
  19. # remove all temp files
  20. rm -rf *~
  21. # fix linking
  22. sed -i \
  23. -e "s:\${KDE4_KDECORE_LIBS}:\${KDE4_KIO_LIBS}:g" \
  24. CMakeLists.txt || die "sed linking failed"
  25. }