lxrandr-0.1.2.ebuild 611 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit autotools eutils
  5. DESCRIPTION="LXDE GUI interface to RandR extention"
  6. HOMEPAGE="http://lxde.sf.net/"
  7. SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. KEYWORDS="~alpha amd64 arm ~arm64 ppc x86 ~arm-linux ~x86-linux"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="x11-libs/gtk+:2
  13. x11-libs/libXrandr
  14. x11-apps/xrandr"
  15. DEPEND="${RDEPEND}
  16. x11-proto/randrproto
  17. virtual/pkgconfig
  18. sys-devel/gettext
  19. >=dev-util/intltool-0.40.0"
  20. src_install () {
  21. emake DESTDIR="${D}" install
  22. dodoc AUTHORS
  23. }