caja-1.12.7-r2.ebuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate virtualx
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="amd64 ~arm x86"
  8. fi
  9. DESCRIPTION="Caja file manager for the MATE desktop"
  10. LICENSE="GPL-2 LGPL-2 FDL-1.1"
  11. SLOT="0"
  12. IUSE="gtk3 +introspection +mate packagekit xmp"
  13. RDEPEND="dev-libs/atk:0
  14. >=dev-libs/glib-2.36:2
  15. >=dev-libs/libxml2-2.4.7:2
  16. gnome-base/dconf:0
  17. >=gnome-base/gvfs-1.10.1:0[udisks]
  18. >=mate-base/mate-desktop-1.9:0[gtk3(-)=]
  19. >=media-libs/libexif-0.6.14:0
  20. x11-libs/cairo:0
  21. x11-libs/gdk-pixbuf:2
  22. x11-libs/libICE:0
  23. x11-libs/libSM:0
  24. x11-libs/libX11:0
  25. x11-libs/libXext:0
  26. x11-libs/libXft:0
  27. x11-libs/libXrender:0
  28. >=x11-libs/pango-1.1.2:0
  29. virtual/libintl:0
  30. !gtk3? (
  31. >=dev-libs/libunique-1:1
  32. >=x11-libs/gtk+-2.24:2[introspection?]
  33. )
  34. gtk3? (
  35. >=dev-libs/libunique-3:3
  36. >=x11-libs/gtk+-3.0:3[introspection?]
  37. )
  38. introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
  39. packagekit? ( app-admin/packagekit-base )
  40. xmp? ( >=media-libs/exempi-1.99.5:2 )"
  41. DEPEND="${RDEPEND}
  42. !!mate-base/mate-file-manager
  43. >=dev-lang/perl-5:0=
  44. dev-util/gdbus-codegen:0
  45. dev-util/gtk-doc
  46. dev-util/gtk-doc-am
  47. >=dev-util/intltool-0.40.1:*
  48. sys-devel/gettext:*
  49. virtual/pkgconfig:*"
  50. PDEPEND="mate? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"
  51. # TODO: Test fails because Caja is not merged yet:
  52. # GLib-GIO-ERROR **: Settings schema 'org.mate.caja.preferences' is not installed
  53. RESTRICT="test"
  54. src_prepare() {
  55. # Remove unnecessary CFLAGS.
  56. sed -i -e 's:-DG.*DISABLE_DEPRECATED::g' \
  57. configure{,.ac} eel/Makefile.{am,in} || die
  58. mate_src_prepare
  59. }
  60. src_configure() {
  61. mate_src_configure \
  62. --disable-update-mimedb \
  63. --with-gtk=$(usex gtk3 3.0 2.0) \
  64. $(use_enable introspection) \
  65. $(use_enable packagekit) \
  66. $(use_enable xmp)
  67. }
  68. src_test() {
  69. unset SESSION_MANAGER
  70. unset DBUS_SESSION_BUS_ADDRESS
  71. Xemake check || die "Test phase failed"
  72. }
  73. pkg_postinst() {
  74. mate_pkg_postinst
  75. elog "Caja can use gstreamer to preview audio files. Just make sure"
  76. elog "to have the necessary plugins available to play the media type you"
  77. elog "want to preview."
  78. }