libmatekbd-1.12.1-r2.ebuild 901 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="amd64 ~arm x86"
  8. fi
  9. DESCRIPTION="MATE keyboard configuration library"
  10. LICENSE="LGPL-2"
  11. SLOT="0"
  12. IUSE="X gtk3 +introspection test"
  13. RDEPEND=">=dev-libs/glib-2.36:2
  14. x11-libs/cairo:0
  15. >=x11-libs/gdk-pixbuf-2.24:2
  16. x11-libs/libX11:0
  17. >=x11-libs/libxklavier-5.0:0
  18. x11-libs/pango:0
  19. virtual/libintl:0
  20. !gtk3? ( >=x11-libs/gtk+-2.24:2[introspection?] )
  21. gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
  22. introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
  23. DEPEND="${RDEPEND}
  24. sys-devel/gettext:*
  25. >=dev-util/intltool-0.50.1:*
  26. virtual/pkgconfig:*"
  27. src_configure() {
  28. mate_src_configure \
  29. --with-gtk=$(usex gtk3 3.0 2.0) \
  30. $(use_with X x) \
  31. $(use_enable introspection) \
  32. $(use_enable test tests)
  33. }