mate-desktop-1.12.1-r2.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit mate multilib python-r1
  7. if [[ ${PV} != 9999 ]]; then
  8. KEYWORDS="amd64 ~arm x86"
  9. fi
  10. DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
  11. LICENSE="GPL-2 FDL-1.1 LGPL-2"
  12. SLOT="0"
  13. IUSE="X debug gtk3 +introspection startup-notification"
  14. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  15. RDEPEND="${PYTHON_DEPS}
  16. >=dev-libs/glib-2.36:2
  17. x11-libs/cairo:0
  18. >=x11-libs/gdk-pixbuf-2.4:2[introspection?]
  19. x11-libs/libX11:0
  20. >=x11-libs/libXrandr-1.3:0
  21. virtual/libintl:0
  22. !gtk3? ( >=x11-libs/gtk+-2.24:2[introspection?] )
  23. gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
  24. introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
  25. startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
  26. DEPEND="${RDEPEND}
  27. app-text/docbook-xml-dtd:4.1.2
  28. dev-util/gtk-doc
  29. dev-util/gtk-doc-am
  30. >=dev-util/intltool-0.40:*
  31. >=gnome-base/dconf-0.13.4:0
  32. sys-devel/gettext:*
  33. >=x11-proto/randrproto-1.3:0
  34. x11-proto/xproto:0
  35. virtual/pkgconfig:*"
  36. src_configure() {
  37. mate_src_configure \
  38. --enable-mate-about \
  39. --disable-mate-conf-import \
  40. --with-gtk=$(usex gtk3 3.0 2.0) \
  41. $(use_with X x) \
  42. $(use_enable debug) \
  43. $(use_enable introspection) \
  44. $(use_enable startup-notification)
  45. }