mate-menus-1.12.0-r1.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit python-r1 mate
  7. if [[ ${PV} != 9999 ]]; then
  8. KEYWORDS="amd64 ~arm x86"
  9. fi
  10. DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
  11. LICENSE="GPL-2 LGPL-2"
  12. SLOT="0"
  13. IUSE="debug +introspection python"
  14. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  15. RDEPEND=">=dev-libs/glib-2.36.0:2
  16. virtual/libintl:0
  17. introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
  18. python? (
  19. dev-python/pygtk:2[${PYTHON_USEDEP}]
  20. ${PYTHON_DEPS}
  21. )"
  22. DEPEND="${RDEPEND}
  23. >=dev-util/intltool-0.40:*
  24. sys-devel/gettext:*
  25. virtual/pkgconfig:*"
  26. src_prepare() {
  27. mate_src_prepare
  28. use python && python_copy_sources
  29. }
  30. src_configure() {
  31. # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
  32. # usage checks.
  33. mate_py_cond_func_wrap mate_src_configure \
  34. --enable-debug=$(usex debug yes minimum) \
  35. $(use_enable python) \
  36. $(use_enable introspection)
  37. }
  38. src_compile() {
  39. mate_py_cond_func_wrap default
  40. }
  41. src_test() {
  42. mate_py_cond_func_wrap emake check
  43. }
  44. src_install() {
  45. mate_py_cond_func_wrap mate_src_install
  46. exeinto /etc/X11/xinit/xinitrc.d/
  47. doexe "${FILESDIR}/10-xdg-menu-mate"
  48. }
  49. pkg_postinst() {
  50. mate_pkg_postinst
  51. einfo "Due to upstream bug"
  52. einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
  53. einfo "it is highly recommended to run the following command"
  54. einfo "once you have logged in to your desktop for the first time:"
  55. einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
  56. }