mate-menus-1.16.0.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. PYTHON_COMPAT=( python2_7 )
  6. inherit python-r1 mate
  7. if [[ ${PV} != 9999 ]]; then
  8. KEYWORDS="~amd64 ~arm ~x86"
  9. fi
  10. DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
  11. LICENSE="GPL-2 LGPL-2"
  12. SLOT="0"
  13. IUSE="debug +introspection python"
  14. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  15. COMMON_DEPEND=">=dev-libs/glib-2.36.0:2
  16. virtual/libintl:0
  17. introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
  18. python? (
  19. dev-python/pygtk:2[${PYTHON_USEDEP}]
  20. ${PYTHON_DEPS}
  21. )"
  22. RDEPEND="${COMMON_DEPEND}"
  23. DEPEND="${COMMON_DEPEND}
  24. >=dev-util/intltool-0.40:*
  25. sys-devel/gettext:*
  26. virtual/pkgconfig:*"
  27. src_prepare() {
  28. mate_src_prepare
  29. use python && python_copy_sources
  30. }
  31. src_configure() {
  32. # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
  33. # usage checks.
  34. mate_py_cond_func_wrap mate_src_configure \
  35. --enable-debug=$(usex debug yes minimum) \
  36. $(use_enable python) \
  37. $(use_enable introspection)
  38. }
  39. src_compile() {
  40. mate_py_cond_func_wrap default
  41. }
  42. src_test() {
  43. mate_py_cond_func_wrap emake check
  44. }
  45. src_install() {
  46. mate_py_cond_func_wrap mate_src_install
  47. exeinto /etc/X11/xinit/xinitrc.d/
  48. doexe "${FILESDIR}/10-xdg-menu-mate"
  49. }
  50. pkg_postinst() {
  51. mate_pkg_postinst
  52. einfo "Due to upstream bug"
  53. einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
  54. einfo "it is highly recommended to run the following command"
  55. einfo "once you have logged in to your desktop for the first time:"
  56. einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
  57. }