mate-panel-1.12.2-r3.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="amd64 ~arm x86"
  8. fi
  9. DESCRIPTION="The MATE panel"
  10. LICENSE="GPL-2 FDL-1.1 LGPL-2"
  11. SLOT="0"
  12. IUSE="X gtk3 +introspection"
  13. RDEPEND="
  14. dev-libs/atk:0
  15. >=dev-libs/dbus-glib-0.80:0
  16. >=dev-libs/glib-2.36:2
  17. >=dev-libs/libmateweather-1.7[gtk3(-)=]
  18. dev-libs/libxml2:2
  19. >=gnome-base/dconf-0.10:0
  20. gnome-base/librsvg:2
  21. >=mate-base/mate-desktop-1.9.3[gtk3(-)=]
  22. >=mate-base/mate-menus-1.6
  23. >=sys-apps/dbus-1.1.2:0
  24. >=x11-libs/cairo-1:0
  25. >=x11-libs/gdk-pixbuf-2.7.1:2
  26. x11-libs/libICE:0
  27. x11-libs/libSM:0
  28. x11-libs/libX11:0
  29. >=x11-libs/pango-1.15.4:0[introspection?]
  30. x11-libs/libXau:0
  31. >=x11-libs/libXrandr-1.3:0
  32. virtual/libintl:0
  33. !gtk3? (
  34. media-libs/libcanberra:0[gtk]
  35. >=x11-libs/gtk+-2.19.7:2[introspection?]
  36. >=x11-libs/libwnck-2.30:1[introspection?]
  37. )
  38. gtk3? (
  39. media-libs/libcanberra:0[gtk3]
  40. >=x11-libs/gtk+-3.0:3[introspection?]
  41. >=x11-libs/libwnck-3.0:3[introspection?]
  42. )
  43. introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
  44. DEPEND="${RDEPEND}
  45. app-text/docbook-xml-dtd:4.1.2
  46. app-text/yelp-tools:0
  47. >=dev-lang/perl-5:0=
  48. dev-util/gtk-doc
  49. dev-util/gtk-doc-am
  50. >=dev-util/intltool-0.50.1:*
  51. sys-devel/gettext:*
  52. virtual/pkgconfig:*"
  53. MATE_FORCE_AUTORECONF=true
  54. src_prepare() {
  55. # Disable python check.
  56. sed -e '/AM_PATH_PYTHON/d' -i configure.ac || die
  57. mate_src_prepare
  58. }
  59. src_configure() {
  60. mate_src_configure \
  61. --libexecdir=/usr/libexec/mate-applets \
  62. --disable-deprecation-flags \
  63. --with-gtk=$(usex gtk3 3.0 2.0) \
  64. $(use_with X x) \
  65. $(use_enable introspection)
  66. }