mate-settings-daemon-1.16.0.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="~amd64 ~arm ~x86"
  8. fi
  9. DESCRIPTION="MATE Settings Daemon"
  10. LICENSE="GPL-2 LGPL-2.1"
  11. SLOT="0"
  12. IUSE="X debug gtk3 libnotify policykit pulseaudio smartcard +sound"
  13. REQUIRED_USE="pulseaudio? ( sound )"
  14. COMMON_DEPEND=">=dev-libs/dbus-glib-0.74:0
  15. >=dev-libs/glib-2.17.3:2
  16. >=gnome-base/dconf-0.13.4:0
  17. >=mate-base/libmatekbd-1.7[gtk3(-)=]
  18. >=mate-base/mate-desktop-1.9[gtk3(-)=]
  19. media-libs/fontconfig:1.0
  20. x11-libs/cairo:0
  21. x11-libs/gdk-pixbuf:2
  22. x11-libs/libX11:0
  23. x11-libs/libXi:0
  24. x11-libs/libXext:0
  25. x11-libs/libXxf86misc:0
  26. >=x11-libs/libxklavier-5:0
  27. virtual/libintl:0
  28. !gtk3? ( >=x11-libs/gtk+-2.24:2 )
  29. gtk3? ( >=x11-libs/gtk+-3.0:3 )
  30. libnotify? ( >=x11-libs/libnotify-0.7:0 )
  31. policykit? (
  32. >=dev-libs/dbus-glib-0.71:0
  33. >=sys-apps/dbus-1.1.2:0
  34. >=sys-auth/polkit-0.97:0
  35. )
  36. pulseaudio? (
  37. >=media-libs/libmatemixer-1.10:0[pulseaudio]
  38. >=media-sound/pulseaudio-0.9.15:0
  39. )
  40. smartcard? ( >=dev-libs/nss-3.11.2:0 )
  41. sound? (
  42. >=media-libs/libmatemixer-1.9
  43. !gtk3? ( media-libs/libcanberra:0[gtk] )
  44. gtk3? ( media-libs/libcanberra:0[gtk3] )
  45. )"
  46. RDEPEND="${COMMON_DEPEND}"
  47. DEPEND="${COMMON_DEPEND}
  48. >=dev-util/intltool-0.50.1:0
  49. sys-devel/gettext:0
  50. virtual/pkgconfig:0
  51. x11-proto/inputproto:0
  52. x11-proto/xproto:0"
  53. src_configure() {
  54. mate_src_configure \
  55. --with-gtk=$(usex gtk3 3.0 2.0) \
  56. $(use_with X x) \
  57. $(use_with libnotify) \
  58. $(use_with sound libcanberra) \
  59. $(use_with sound libmatemixer) \
  60. $(use_enable debug) \
  61. $(use_enable policykit polkit) \
  62. $(use_enable pulseaudio pulse) \
  63. $(use_enable smartcard smartcard-support)
  64. }