caja-extensions-1.14.1-r1.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="~amd64 ~arm ~x86"
  8. fi
  9. DESCRIPTION="Several Caja extensions"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. SENDTO="cdr gajim +mail pidgin upnp"
  13. IUSE="gksu gtk3 image-converter +open-terminal share +wallpaper ${SENDTO}"
  14. COMMON_DEPEND=">=dev-libs/glib-2.36:2
  15. >=mate-base/caja-1.7[gtk3(-)=]
  16. virtual/libintl:0
  17. x11-libs/gdk-pixbuf:2
  18. gajim? (
  19. >=dev-libs/dbus-glib-0.60:0
  20. >=sys-apps/dbus-1:0
  21. )
  22. !gtk3? ( >=x11-libs/gtk+-2.24:2 )
  23. gtk3? ( >=x11-libs/gtk+-3.0:3 )
  24. open-terminal? ( >=mate-base/mate-desktop-1.7[gtk3(-)=] )
  25. pidgin? ( >=dev-libs/dbus-glib-0.60:0 )
  26. upnp? ( >=net-libs/gupnp-0.13:0= )"
  27. RDEPEND="${COMMON_DEPEND}
  28. cdr? ( >=app-cdr/brasero-2.32.1:0= )
  29. gajim? ( net-im/gajim:0 )
  30. gksu? ( x11-libs/gksu )
  31. image-converter? ( virtual/imagemagick-tools )
  32. pidgin? ( net-im/pidgin )"
  33. DEPEND="${COMMON_DEPEND}
  34. dev-util/gtk-doc
  35. dev-util/gtk-doc-am
  36. >=dev-util/intltool-0.18:*
  37. sys-devel/gettext:*
  38. virtual/pkgconfig:*
  39. !!mate-extra/mate-file-manager-open-terminal
  40. !!mate-extra/mate-file-manager-sendto
  41. !!mate-extra/mate-file-manager-image-converter
  42. !!mate-extra/mate-file-manager-share"
  43. src_configure() {
  44. local sendto_plugins="removable-devices"
  45. use cdr && sendto_plugins+=",caja-burn"
  46. use mail && sendto_plugins+=",emailclient"
  47. use pidgin && sendto_plugins+=",pidgin"
  48. use gajim && sendto_plugins+=",gajim"
  49. use upnp && sendto_plugins+=",upnp"
  50. mate_src_configure \
  51. --enable-sendto \
  52. --with-sendto-plugins=${sendto_plugins}\
  53. --with-gtk=$(usex gtk3 3.0 2.0) \
  54. $(use_enable gksu) \
  55. $(use_enable image-converter) \
  56. $(use_enable open-terminal) \
  57. $(use_enable share) \
  58. $(use_enable wallpaper)
  59. }