mate-polkit-1.12.0-r2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit mate
  5. if [[ ${PV} != 9999 ]]; then
  6. KEYWORDS="amd64 ~arm x86"
  7. fi
  8. DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. IUSE="accountsservice appindicator debug examples gtk3 +introspection"
  12. RDEPEND=">=dev-libs/glib-2.36:2
  13. >=sys-auth/polkit-0.102:0[introspection?]
  14. x11-libs/gdk-pixbuf:2[introspection?]
  15. virtual/libintl:0
  16. accountsservice? ( sys-apps/accountsservice:0[introspection?] )
  17. !gtk3? (
  18. >=x11-libs/gtk+-2.24:2[introspection?]
  19. appindicator? ( dev-libs/libappindicator:2 )
  20. )
  21. gtk3? (
  22. >=x11-libs/gtk+-3.0:3[introspection?]
  23. appindicator? ( dev-libs/libappindicator:3 )
  24. )
  25. introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )"
  26. DEPEND="${RDEPEND}
  27. dev-util/gtk-doc
  28. dev-util/gtk-doc-am
  29. >=dev-util/intltool-0.35:*
  30. sys-devel/gettext:*
  31. >=sys-devel/libtool-2.2.6
  32. virtual/pkgconfig:*
  33. !<gnome-extra/polkit-gnome-0.102:0"
  34. src_configure() {
  35. mate_src_configure \
  36. --disable-static \
  37. --with-gtk=$(usex gtk3 3.0 2.0) \
  38. $(use_enable accountsservice) \
  39. $(use_enable appindicator) \
  40. $(use_enable debug) \
  41. $(use_enable examples) \
  42. $(use_enable introspection)
  43. }