mate-polkit-1.14.0.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit mate
  5. if [[ ${PV} != 9999 ]]; then
  6. KEYWORDS="~amd64 ~arm ~x86"
  7. fi
  8. DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. IUSE="accountsservice appindicator debug examples gtk3 +introspection"
  12. COMMON_DEPEND=">=dev-libs/glib-2.36:2
  13. >=sys-auth/polkit-0.102:0[introspection?]
  14. x11-libs/gdk-pixbuf:2[introspection?]
  15. virtual/libintl:0
  16. !gtk3? (
  17. >=x11-libs/gtk+-2.24:2[introspection?]
  18. appindicator? ( dev-libs/libappindicator:2 )
  19. )
  20. gtk3? (
  21. >=x11-libs/gtk+-3.0:3[introspection?]
  22. appindicator? ( dev-libs/libappindicator:3 )
  23. )
  24. introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )"
  25. RDEPEND="${COMMON_DEPEND}
  26. accountsservice? ( sys-apps/accountsservice:0[introspection?] )"
  27. DEPEND="${COMMON_DEPEND}
  28. dev-util/gtk-doc
  29. dev-util/gtk-doc-am
  30. >=dev-util/intltool-0.35:*
  31. sys-devel/gettext:*
  32. >=sys-devel/libtool-2.2.6
  33. virtual/pkgconfig:*
  34. !<gnome-extra/polkit-gnome-0.102:0"
  35. src_configure() {
  36. mate_src_configure \
  37. --disable-static \
  38. --with-gtk=$(usex gtk3 3.0 2.0) \
  39. $(use_enable accountsservice) \
  40. $(use_enable appindicator) \
  41. $(use_enable debug) \
  42. $(use_enable examples) \
  43. $(use_enable introspection)
  44. }