mate-system-monitor-1.12.2.ebuild 1015 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit mate
  5. if [[ ${PV} != 9999 ]]; then
  6. KEYWORDS="amd64 ~arm x86"
  7. fi
  8. DESCRIPTION="The MATE System Monitor"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE="gtk3 systemd"
  12. RDEPEND="
  13. >=dev-cpp/glibmm-2.26:2
  14. >=dev-libs/dbus-glib-0.70:0
  15. >=dev-libs/glib-2.36:2
  16. dev-libs/libsigc++:2
  17. >=dev-libs/libxml2-2:2
  18. >=gnome-base/libgtop-2.23.1:2=
  19. >=gnome-base/librsvg-2.35:2
  20. >=sys-apps/dbus-0.7:0
  21. x11-libs/cairo:0
  22. x11-libs/gdk-pixbuf:2
  23. virtual/libintl:0
  24. !gtk3? (
  25. >=dev-cpp/gtkmm-2.22:2.4
  26. >=x11-libs/gtk+-2.20:2
  27. >=x11-libs/libwnck-2.5:1
  28. )
  29. gtk3? (
  30. >=dev-cpp/gtkmm-3.0:3.0
  31. >=x11-libs/gtk+-3.0:3
  32. >=x11-libs/libwnck-2.91:3
  33. )
  34. systemd? ( sys-apps/systemd )"
  35. DEPEND="${RDEPEND}
  36. app-text/yelp-tools:0
  37. >=dev-util/intltool-0.50.1:*
  38. sys-devel/gettext:*
  39. >=sys-devel/autoconf-2.63:*
  40. virtual/pkgconfig:*"
  41. src_configure() {
  42. mate_src_configure \
  43. --with-gtk=$(usex gtk3 3.0 2.0) \
  44. $(use_enable systemd)
  45. }