mate-system-monitor-1.14.0.ebuild 985 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit mate
  5. if [[ ${PV} != 9999 ]]; then
  6. KEYWORDS="~amd64 ~arm ~x86"
  7. fi
  8. DESCRIPTION="The MATE System Monitor"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE="systemd"
  12. COMMON_DEPEND="
  13. >=dev-cpp/glibmm-2.26:2
  14. >=dev-cpp/gtkmm-3.8:3.0
  15. >=dev-libs/glib-2.36:2
  16. dev-libs/libsigc++:2
  17. >=dev-libs/libxml2-2:2
  18. >=gnome-base/libgtop-2.23.1:2=
  19. >=gnome-base/librsvg-2.35:2
  20. x11-libs/cairo:0
  21. x11-libs/gdk-pixbuf:2
  22. >=x11-libs/gtk+-3.14:3
  23. >=x11-libs/libwnck-3.0:3
  24. virtual/libintl:0
  25. systemd? ( sys-apps/systemd )"
  26. RDEPEND="${COMMON_DEPEND}"
  27. DEPEND="${COMMON_DEPEND}
  28. app-text/yelp-tools:0
  29. >=dev-util/intltool-0.50.1:*
  30. sys-devel/gettext:*
  31. >=sys-devel/autoconf-2.63:*
  32. virtual/pkgconfig:*"
  33. src_configure() {
  34. mate_src_configure \
  35. $(use_enable systemd)
  36. }
  37. pkg_postinst() {
  38. mate_pkg_postinst
  39. einfo "${PN} may run commands with escalated privileges using"
  40. einfo "x11-libs/gksu."
  41. }